summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-15 17:15:51 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-15 17:22:24 +0200
commit2d6225081a2d4c282b1ad93d08812fb6585c5984 (patch)
tree7d47a08b47630e63f0bb1fec410b19d5febf02c2 /dev-python/thunarx-python
parentdev-util/dbus-test-runner: Port to py3.{7..9} (diff)
downloadgentoo-2d6225081a2d4c282b1ad93d08812fb6585c5984.tar.gz
gentoo-2d6225081a2d4c282b1ad93d08812fb6585c5984.tar.bz2
gentoo-2d6225081a2d4c282b1ad93d08812fb6585c5984.zip
dev-python/thunarx-python: Port to py3.{7..9}
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/thunarx-python')
-rw-r--r--dev-python/thunarx-python/files/thunarx-python-0.5.1-py38.patch27
-rw-r--r--dev-python/thunarx-python/thunarx-python-0.5.1-r1.ebuild6
2 files changed, 32 insertions, 1 deletions
diff --git a/dev-python/thunarx-python/files/thunarx-python-0.5.1-py38.patch b/dev-python/thunarx-python/files/thunarx-python-0.5.1-py38.patch
new file mode 100644
index 000000000000..19ad0886ad52
--- /dev/null
+++ b/dev-python/thunarx-python/files/thunarx-python-0.5.1-py38.patch
@@ -0,0 +1,27 @@
+From 78b24f3bf34c1faafcdc5816856bc9bf1bfaed6f Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Wed, 15 Jul 2020 17:19:34 +0200
+Subject: [PATCH] Fix compilation with python3.8
+
+Based on upstream commit 5f4edd0b657f52619b60e9931340502fa87f49ff,
+stripped off irrelevant changes, made directly in configure.
+---
+ configure | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure b/configure
+index 9fabaa0..ff2ceae 100755
+--- a/configure
++++ b/configure
+@@ -13557,7 +13557,7 @@ py_lib_name=`basename $py_include_path`
+ if test "x$PYTHON_LIBS" = x; then
+ PYTHON_CONFIG=`which $PYTHON`-config
+ if test -x "$PYTHON_CONFIG"; then
+- PYTHON_LIBS=`$PYTHON_CONFIG --ldflags 2>/dev/null`
++ PYTHON_LIBS=`$PYTHON_CONFIG --libs --embed 2>/dev/null` || PYTHON_LIBS=`$PYTHON_CONFIG --libs 2>/dev/null`
+ else
+ PYTHON_LIBS="-L${py_prefix}/lib -lpython${PYTHON_VERSION}"
+ fi
+--
+2.27.0
+
diff --git a/dev-python/thunarx-python/thunarx-python-0.5.1-r1.ebuild b/dev-python/thunarx-python/thunarx-python-0.5.1-r1.ebuild
index 0a243f4cf713..d2bb115a4a8c 100644
--- a/dev-python/thunarx-python/thunarx-python-0.5.1-r1.ebuild
+++ b/dev-python/thunarx-python/thunarx-python-0.5.1-r1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python3_6 )
+PYTHON_COMPAT=( python3_{6..9} )
inherit python-single-r1
@@ -26,6 +26,10 @@ DEPEND="${RDEPEND}
virtual/pkgconfig"
REQUIRED_USE=${PYTHON_REQUIRED_USE}
+PATCHES=(
+ "${FILESDIR}"/${P}-py38.patch
+)
+
src_install() {
default