summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-29 05:07:55 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-29 05:16:27 +0200
commita9f5909096d80c909efed2207f18c6e7e222c8db (patch)
treea180d79628510814facb273e8c9c79dedaefb2cb /dev-python
parentdev-python/sphinxcontrib-devhelp: Bump to 2.0.0 (diff)
downloadgentoo-a9f5909096d80c909efed2207f18c6e7e222c8db.tar.gz
gentoo-a9f5909096d80c909efed2207f18c6e7e222c8db.tar.bz2
gentoo-a9f5909096d80c909efed2207f18c6e7e222c8db.zip
dev-python/sphinxcontrib-htmlhelp: Bump to 2.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/sphinxcontrib-htmlhelp/Manifest1
-rw-r--r--dev-python/sphinxcontrib-htmlhelp/sphinxcontrib-htmlhelp-2.1.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-htmlhelp/Manifest b/dev-python/sphinxcontrib-htmlhelp/Manifest
index 612f0d0ee81e..03a784bb3097 100644
--- a/dev-python/sphinxcontrib-htmlhelp/Manifest
+++ b/dev-python/sphinxcontrib-htmlhelp/Manifest
@@ -1,2 +1,3 @@
DIST sphinxcontrib_htmlhelp-2.0.5.tar.gz 21925 BLAKE2B ba023e53c14b5427b09a9608cfc45ccdf932d4c27cce40932088fadb127ebfe50d7b2639513589469facf108fdc748e0f07195766e6e4bc67d26c50d00a2bf75 SHA512 537ef6a1a32863728a6324fcd50f9374e4f488ed7ed112f9f0ceb9e4488637f502280dda21835e8d63c6b6297d2a3db3032c3f307dce5948b516f293d07b9711
DIST sphinxcontrib_htmlhelp-2.0.6.tar.gz 21957 BLAKE2B 44b03832d8b89978062028be32a1253f2d5f2134b83f7e95fc685ab669ae3b4131dbad452e49d84cef56993a701f1cc1fbf1f50583fdc114eed7a05ad261c5ac SHA512 842194261315b35c470dee36ea7945b73dd08338f2b86d542b3a21d1cb900a2fbe0ba8ec2412589b4c8993b71d88b0e4fcfb0e3316db61c8ba2989811d3e073e
+DIST sphinxcontrib_htmlhelp-2.1.0.tar.gz 22617 BLAKE2B c9c97e4b879de3c4220795d6356925e70f09c6705740fafe609d2e1c02585c2f86a00e985969e60dd100bd26408a910d78e5537317d8e101e227b633bd2292c1 SHA512 9aa2650ed27712a94de6ea16954db952db9c4a0c5f509aba42e33c69ba46f7069e9ee01c09a31e531fd096882c0248cf72334404d717a9f35aafc22e3976530e
diff --git a/dev-python/sphinxcontrib-htmlhelp/sphinxcontrib-htmlhelp-2.1.0.ebuild b/dev-python/sphinxcontrib-htmlhelp/sphinxcontrib-htmlhelp-2.1.0.ebuild
new file mode 100644
index 000000000000..85c62da13499
--- /dev/null
+++ b/dev-python/sphinxcontrib-htmlhelp/sphinxcontrib-htmlhelp-2.1.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Sphinx extension which outputs HTML help book"
+HOMEPAGE="
+ https://www.sphinx-doc.org/
+ https://github.com/sphinx-doc/sphinxcontrib-htmlhelp/
+ https://pypi.org/project/sphinxcontrib-htmlhelp/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+PDEPEND="
+ >=dev-python/sphinx-5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${PDEPEND}
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest