summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/libao
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/libao')
-rw-r--r--media-libs/libao/Manifest2
-rw-r--r--media-libs/libao/libao-1.1.0-r1.ebuild45
-rw-r--r--media-libs/libao/libao-1.1.0-r2.ebuild51
-rw-r--r--media-libs/libao/libao-1.2.0.ebuild51
-rw-r--r--media-libs/libao/metadata.xml5
5 files changed, 154 insertions, 0 deletions
diff --git a/media-libs/libao/Manifest b/media-libs/libao/Manifest
new file mode 100644
index 000000000000..b45e471e3efa
--- /dev/null
+++ b/media-libs/libao/Manifest
@@ -0,0 +1,2 @@
+DIST libao-1.1.0.tar.gz 397102 SHA256 29de5bb9b1726ba890455ef7e562d877df87811febb0d99ee69164b88c171bd4 SHA512 8eee73cfd3ffd79b5cae76fc3ad88270b56cc49dfbf4599c4ed591b259b79475e396c984abde94118a916fba20db84e26ac8e51dbf5efd4bb10341328ca0615a WHIRLPOOL 2bb1f946ceb89e44373850bd53696a41c57ef9902d760ef485368163ca3efaf622c0faf06a46c609e03c9fb2dc5b0f51c9f45020981cba199024ea581d859d26
+DIST libao-1.2.0.tar.gz 464596 SHA256 03ad231ad1f9d64b52474392d63c31197b0bc7bd416e58b1c10a329a5ed89caf SHA512 9456953826c188d67129ad78366bb86d6243499f2cd340d20d61366f7e40a33f3f8ab601c7f18ce9e24aa22f898093b482b2415b7e428c1486ef7e5ac27b3ee4 WHIRLPOOL 00bca36fd033775f9fb8551ce20425d7c3ebd138174692831f256fbcef306e391479ae63a8bd25fa4995a2ff53ba5e478317ef6c3b5028925a737b08189f4bf2
diff --git a/media-libs/libao/libao-1.1.0-r1.ebuild b/media-libs/libao/libao-1.1.0-r1.ebuild
new file mode 100644
index 000000000000..2375cacf67e0
--- /dev/null
+++ b/media-libs/libao/libao-1.1.0-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit libtool multilib eutils
+
+DESCRIPTION="The Audio Output library"
+HOMEPAGE="http://www.xiph.org/ao/"
+SRC_URI="http://downloads.xiph.org/releases/ao/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~x86-fbsd ~x86-interix ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="alsa nas mmap pulseaudio static-libs"
+
+RDEPEND="alsa? ( media-libs/alsa-lib )
+ nas? ( media-libs/nas )
+ pulseaudio? ( media-sound/pulseaudio )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ sed -i -e 's:-O20::' configure || die
+ sed -i -e "s:/lib:/$(get_libdir):g" ao.m4 || die
+ elibtoolize
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ --disable-esd \
+ $(use_enable alsa alsa) \
+ $(use_enable mmap alsa-mmap) \
+ --disable-arts \
+ $(use_enable nas) \
+ $(use_enable pulseaudio pulse)
+}
+
+src_install() {
+ emake DESTDIR="${D}" docdir="${EPREFIX}/usr/share/doc/${PF}/html" install
+ dodoc AUTHORS CHANGES README TODO
+ prune_libtool_files --all
+}
diff --git a/media-libs/libao/libao-1.1.0-r2.ebuild b/media-libs/libao/libao-1.1.0-r2.ebuild
new file mode 100644
index 000000000000..d80a5a46e72e
--- /dev/null
+++ b/media-libs/libao/libao-1.1.0-r2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit libtool multilib multilib-minimal eutils
+
+DESCRIPTION="The Audio Output library"
+HOMEPAGE="http://www.xiph.org/ao/"
+SRC_URI="http://downloads.xiph.org/releases/ao/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="alsa nas mmap pulseaudio static-libs"
+
+RDEPEND="alsa? ( >=media-libs/alsa-lib-1.0.27.2[${MULTILIB_USEDEP}] )
+ nas? ( >=media-libs/nas-1.9.4[${MULTILIB_USEDEP}] )
+ pulseaudio? ( >=media-sound/pulseaudio-2.1-r1[${MULTILIB_USEDEP}] )
+ abi_x86_32? ( !<=app-emulation/emul-linux-x86-soundlibs-20131008-r1
+ !app-emulation/emul-linux-x86-soundlibs[-abi_x86_32(-)] )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ sed -i -e 's:-O20::' configure || die
+ sed -i -e "s:/lib:/$(get_libdir):g" ao.m4 || die
+ elibtoolize
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ econf \
+ $(use_enable static-libs static) \
+ --disable-esd \
+ $(use_enable alsa alsa) \
+ $(use_enable mmap alsa-mmap) \
+ --disable-arts \
+ $(use_enable nas) \
+ $(use_enable pulseaudio pulse)
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" docdir="${EPREFIX}/usr/share/doc/${PF}/html" install
+}
+
+multilib_src_install_all() {
+ dodoc AUTHORS CHANGES README TODO
+ prune_libtool_files --all
+}
diff --git a/media-libs/libao/libao-1.2.0.ebuild b/media-libs/libao/libao-1.2.0.ebuild
new file mode 100644
index 000000000000..f9774d1e35ad
--- /dev/null
+++ b/media-libs/libao/libao-1.2.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit libtool multilib multilib-minimal eutils
+
+DESCRIPTION="The Audio Output library"
+HOMEPAGE="http://www.xiph.org/ao/"
+SRC_URI="http://downloads.xiph.org/releases/ao/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~sh sparc x86 ~x86-fbsd ~x86-interix ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="alsa nas mmap pulseaudio static-libs"
+
+RDEPEND="alsa? ( >=media-libs/alsa-lib-1.0.27.2[${MULTILIB_USEDEP}] )
+ nas? ( >=media-libs/nas-1.9.4[${MULTILIB_USEDEP}] )
+ pulseaudio? ( >=media-sound/pulseaudio-2.1-r1[${MULTILIB_USEDEP}] )
+ abi_x86_32? ( !<=app-emulation/emul-linux-x86-soundlibs-20131008-r1
+ !app-emulation/emul-linux-x86-soundlibs[-abi_x86_32(-)] )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ sed -i 's:-O20::' configure || die
+ sed -i "s:/lib:/$(get_libdir):g" ao.m4 || die
+ elibtoolize
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ econf \
+ $(use_enable static-libs static) \
+ --disable-esd \
+ $(use_enable alsa alsa) \
+ $(use_enable mmap alsa-mmap) \
+ --disable-arts \
+ $(use_enable nas) \
+ $(use_enable pulseaudio pulse)
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" docdir="${EPREFIX}/usr/share/doc/${PF}/html" install
+}
+
+multilib_src_install_all() {
+ dodoc AUTHORS CHANGES README TODO
+ prune_libtool_files --all
+}
diff --git a/media-libs/libao/metadata.xml b/media-libs/libao/metadata.xml
new file mode 100644
index 000000000000..e1774e3d9ad7
--- /dev/null
+++ b/media-libs/libao/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sound</herd>
+</pkgmetadata>