summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-09-23 02:05:43 +0100
committerSam James <sam@gentoo.org>2024-09-23 02:06:53 +0100
commit2ebde6581d1aa42be8c21c701217394e1b33c9a5 (patch)
tree37090461883a48635bf60e7f10b4ff09b823d907 /net-analyzer/cloudshark/cloudshark-1.0.4.ebuild
parentdev-libs/libjcat: Stabilize 0.2.1 ppc64, #940067 (diff)
downloadgentoo-2ebde6581d1aa42be8c21c701217394e1b33c9a5.tar.gz
gentoo-2ebde6581d1aa42be8c21c701217394e1b33c9a5.tar.bz2
gentoo-2ebde6581d1aa42be8c21c701217394e1b33c9a5.zip
net-analyzer/cloudshark: fix invalid PDEPEND use
pkgcheck now reports: ``` net-analyzer/cloudshark BadDependency: version 1.0.4: ':=' operator is invalid in: PDEPEND="net-analyzer/wireshark:=[lua]" ``` This showed up in breaking CI when infra updated pkgcheck. As for the PDEPEND use here in general, it's invalid both because: a) PDEPEND should *only* be used for breaking circular dependencies; b) := is ill-defined in PDEPEND. This is a plugin for Wireshark hence needs to be in DEPEND+RDEPEND. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer/cloudshark/cloudshark-1.0.4.ebuild')
-rw-r--r--net-analyzer/cloudshark/cloudshark-1.0.4.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/net-analyzer/cloudshark/cloudshark-1.0.4.ebuild b/net-analyzer/cloudshark/cloudshark-1.0.4.ebuild
deleted file mode 100644
index 3904b2a51763..000000000000
--- a/net-analyzer/cloudshark/cloudshark-1.0.4.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DESCRIPTION="Easily upload your wireshark captures to CloudShark"
-HOMEPAGE="https://cloudshark.io/articles/wireshark-plugin/ https://github.com/cloudshark/wireshark-plugin"
-SRC_URI="https://github.com/${PN}/wireshark-plugin/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE=""
-
-PDEPEND="net-analyzer/wireshark:=[lua]
- net-misc/curl"
-
-S="${WORKDIR}/wireshark-plugin-${PV}"
-
-get_PV() {
- local pv=$(best_version $1)
- pv=${pv#$1-}; pv=${pv%-r*}
- pv=${pv//_}; echo ${pv}
-}
-
-src_prepare() {
- #cloudshark isn't meant to be installed systemwide, we fix that
- eapply "${FILESDIR}"/cs_log_dir.patch
-
- sed -i "s#%s/cloudshark_init.lua#/usr/$(get_libdir)/wireshark/plugins/$(get_PV net-analyzer/wireshark)/cloudshark_init.lua#" cloudshark.lua
-
- #this enables cloudshark by DEFAULT on tshark, not desired
- #sed -i 's#CLOUDSHARK_TSHARK = "n"#CLOUDSHARK_TSHARK = "y"#' cloudshark_init.default
- default
-}
-
-src_install() {
- insinto /usr/$(get_libdir)/wireshark/plugins/$(get_PV net-analyzer/wireshark)
- doins cloudshark.lua json.lua
- newins cloudshark_init.default cloudshark_init.lua
- dodoc README.md
-}