summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2016-07-20 12:36:27 -0400
committerMichael Orlitzky <mjo@gentoo.org>2016-07-20 12:59:20 -0400
commit94db238da7e1e4e606e24cb84579b3f2bb3e6fbf (patch)
tree3cbac8d7a75038be2a7d15665613c54bcafcbf0b /x11-libs/rep-gtk/rep-gtk-0.90.8.3.ebuild
parentx11-wm/sawfish: new version 1.11.90. (diff)
downloadgentoo-94db238da7e1e4e606e24cb84579b3f2bb3e6fbf.tar.gz
gentoo-94db238da7e1e4e606e24cb84579b3f2bb3e6fbf.tar.bz2
gentoo-94db238da7e1e4e606e24cb84579b3f2bb3e6fbf.zip
x11-libs/rep-gtk: new version 0.90.8.3 updating the ebuild to EAPI=6.
Gentoo-Bug: 493110 Package-Manager: portage-2.2.28
Diffstat (limited to 'x11-libs/rep-gtk/rep-gtk-0.90.8.3.ebuild')
-rw-r--r--x11-libs/rep-gtk/rep-gtk-0.90.8.3.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/x11-libs/rep-gtk/rep-gtk-0.90.8.3.ebuild b/x11-libs/rep-gtk/rep-gtk-0.90.8.3.ebuild
new file mode 100644
index 000000000000..85e30c1fb08c
--- /dev/null
+++ b/x11-libs/rep-gtk/rep-gtk-0.90.8.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools eutils
+
+MY_P="${PN}_${PV}"
+DESCRIPTION="GTK+/libglade/GNOME bindings for the librep Lisp environment"
+HOMEPAGE="http://sawfish.wikia.com/wiki/Main_Page"
+SRC_URI="http://download.tuxfamily.org/librep/${PN}/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="gtk-2.0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="examples"
+
+RDEPEND=">=dev-libs/librep-0.90.5
+ >=dev-libs/glib-2.6:2
+ >=x11-libs/gtk+-2.24.0:2
+ >=x11-libs/gdk-pixbuf-2.23:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ app-arch/xz-utils"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( AUTHORS ChangeLog README README.gtk-defs README.guile-gtk TODO )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --libdir=/usr/$(get_libdir) \
+ --disable-static
+}
+
+src_install() {
+ default
+ use examples && dodoc -r examples
+ find "${D}" -name '*.la' -exec rm -f {} + || die "la file removal failed"
+}