aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarco Leise <marco.leise@gmx.de>2020-03-09 20:01:57 +0100
committerMarco Leise <marco.leise@gmx.de>2020-03-09 20:01:57 +0100
commit7720bff56f66425783d5a4e9b0ddad16dcc42e50 (patch)
treefd35298ffcb5efcb86dc51fbd1eaf099d04fb565 /dev-libs
parentldc2-1.20.1 (diff)
downloaddlang-7720bff56f66425783d5a4e9b0ddad16dcc42e50.tar.gz
dlang-7720bff56f66425783d5a4e9b0ddad16dcc42e50.tar.bz2
dlang-7720bff56f66425783d5a4e9b0ddad16dcc42e50.zip
removed dlang_has_shared_lib_support() function as all offered compilers support shared libs now
Signed-off-by: Marco Leise <marco.leise@gmx.de>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/gtkd/gtkd-2.4.2-r1.ebuild21
-rw-r--r--dev-libs/gtkd/gtkd-3.8.5-r1.ebuild12
2 files changed, 12 insertions, 21 deletions
diff --git a/dev-libs/gtkd/gtkd-2.4.2-r1.ebuild b/dev-libs/gtkd/gtkd-2.4.2-r1.ebuild
index c98a3aa..ad07352 100644
--- a/dev-libs/gtkd/gtkd-2.4.2-r1.ebuild
+++ b/dev-libs/gtkd/gtkd-2.4.2-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -41,13 +41,8 @@ d_src_compile() {
compile_libs() {
# Build the shared library version of the component
# The test phase expects no version extension on the .so
- if dlang_has_shared_lib_support; then
- dlang_compile_lib_so lib${LIB_NAME}-${MAJOR}.so \
- lib${LIB_NAME}-${MAJOR}.so.0 -Isrc ${GTKD_SRC_DIRS[$i]}/*/*.d
- else
- ewarn "${DC} does not have shared library support."
- ewarn "Only static ${LIB_NAME} will be compiled if selected through the static-libs USE flag."
- fi
+ dlang_compile_lib_so lib${LIB_NAME}-${MAJOR}.so \
+ lib${LIB_NAME}-${MAJOR}.so.0 -Isrc ${GTKD_SRC_DIRS[$i]}/*/*.d
# Build the static library version
if use static-libs; then
@@ -76,12 +71,10 @@ d_src_test() {
d_src_install() {
install_libs() {
# Install the shared library version of the component
- if dlang_has_shared_lib_support; then
- local libfile="lib${LIB_NAME}-${MAJOR}.so"
- ln -s "${libfile}" "${libfile}.0"
- ln -s "${libfile}" "${libfile}.0.${MINOR}"
- dolib.so "${libfile}.0.${MINOR}" "${libfile}.0" "${libfile}"
- fi
+ local libfile="lib${LIB_NAME}-${MAJOR}.so"
+ ln -s "${libfile}" "${libfile}.0"
+ ln -s "${libfile}" "${libfile}.0.${MINOR}"
+ dolib.so "${libfile}.0.${MINOR}" "${libfile}.0" "${libfile}"
# Install the static library version
if use static-libs; then
diff --git a/dev-libs/gtkd/gtkd-3.8.5-r1.ebuild b/dev-libs/gtkd/gtkd-3.8.5-r1.ebuild
index acfe068..841f0a9 100644
--- a/dev-libs/gtkd/gtkd-3.8.5-r1.ebuild
+++ b/dev-libs/gtkd/gtkd-3.8.5-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -81,12 +81,10 @@ d_src_test() {
d_src_install() {
install_libs() {
# Install the shared library version of the component
- if dlang_has_shared_lib_support; then
- local libfile="lib${LIB_NAME}-${MAJOR}.so"
- ln -sf "${libfile}" "${libfile}.0"
- ln -sf "${libfile}" "${libfile}.0.${MINOR}"
- dolib.so "${libfile}.0.${MINOR}" "${libfile}.0" "${libfile}"
- fi
+ local libfile="lib${LIB_NAME}-${MAJOR}.so"
+ ln -sf "${libfile}" "${libfile}.0"
+ ln -sf "${libfile}" "${libfile}.0.${MINOR}"
+ dolib.so "${libfile}.0.${MINOR}" "${libfile}.0" "${libfile}"
# Install the static library version
if use static-libs; then